InstallationΒΆ

There are many ways to install GeoServer on your system. This section will discuss the various installation paths available.

Note

To run GeoServer as part of an existing servlet container such as Tomcat, please see the Web archive section.

Warning

GeoServer requires a Java 8 or Java 11 environment (JRE) to be installed on your system, available from OpenJDK, AdoptOpenJDK for Windows and macOS installers, or provided by your OS distribution.

This must be done prior to installation.

Note

At this time we no longer provide a Windows Installer, due to lack of a secure Windows machine where the installer can be built and signed. However if you realy need the Windows installer, you can create one following the instruction on this site.

Previous: License